站长视角
用户至上

修复“您的PHP安装似乎缺少WordPress所需的MySQL扩展”错误

您的PHP安装似乎缺少WordPress所需的MySQL扩展”错误

尝试安装WordPress或访问您的WordPress站点时却遇到错误,提示“您的PHP安装似乎缺少WordPress所需的MySQL扩展。”?英文全称为:Your PHP installation appears to be missing the MySQL extension which is required by WordPress。

与任何WordPress错误消息一样,遇到阻止您使用/访问WordPress站点的问题可能会令人沮丧。

但是,不要绝望!通常,此错误意味着您网站上的代码出现问题,并且某些原因阻止WordPress能够连接到其MySQL数据库

在本文中,我们将讨论“某事”可能是什么,并分享一些有关如何排除故障和修复此错误消息的提示。

是什么导致WordPress缺少MySQL扩展错误?

正如我们在介绍中提到的,错误消息“您的PHP安装似乎缺少WordPress所需的MySQL扩展”是您服务器上的代码/脚本的一些问题的步骤。

具体来说,此错误意味着您服务器上的PHP没有必要的扩展来将您的WordPress站点连接到其MySQL数据库

出现这种情况的主要原因有两个:

1. 您使用的是过时版本的WordPress和PHP 7+

如果您使用的是非常旧版本的WordPress和现代版本的PHP,您可能会遇到此错误,因为PHP 7.0不推荐使用MySQL扩展来支持MySQLi。也就是说,PHP 7+不再包含WordPress正在寻找的MySQL扩展。

现代版本的WordPress将改为使用较新的PDO_MySQL或MySQLi扩展。但是,较旧版本的WordPress(低于 3.9 版)可能会导致此问题。

2. 您使用的是PHP 5.6或更低版本,但缺少扩展或配置不正确

另一个可能的原因是您使用的是PHP 5.6(在 MySQL 扩展被弃用之前),但该扩展丢失或配置不正确。

如何修复“您的PHP安装似乎缺少WordPress所需的MySQL 扩展”

现在您知道发生了什么,让我们回顾一些有关如何排除故障和解决问题的提示。

1. 检查您使用的PHP版本

诊断此问题的第一步是确定您的 WordPress 站点的服务器正在运行哪个版本的PHP。这个问题的答案将决定您接下来要采取的步骤。

要检查这一点,请使用FTP连接到WordPress站点的服务器。您可以从您的网络主机获取您的FTP凭据,您还需要一个FTP客户端来连接。

如果您的主机使用cPanel,您可以使用cPanel文件管理器工具。

连接到服务器后,在WordPress站点的根目录中创建一个名为phpinfo.php的新文件。这应该与包含wp-config.php文件的文件夹相同。

然后,编辑文件并添加以下代码片段:

<?phpphpinfo();?>

保存文件后(并在需要时重新上传保存的版本),导航到yoursite.com/phpinfo.php,确保将yoursite.com替换为您的实际域名

您应该会看到一个屏幕,其中显示了有关服务器上PHP配置的许多不同信息。向下滚动到Core部分并查找PHP Version项。注意数字——你应该看到类似xxx 的东西。例如7.2.255.6.8

如何检查您的WordPress网站的PHP版本

如何检查您的WordPress网站的PHP版本

如果您的PHP版本以“7”开头,则通常意味着您需要更新WordPress软件。另一方面,如果您仍在使用PHP 5.X,您可能会缺少MySQL扩展。

注意 – 我们强烈建议使用最新版本的PHP。事实上,我们不支持PHP 7.4以下的版本。这些旧版本的性能较慢,并且由于它们不再接收安全更新,因此可能对您的站点构成安全风险。

2. 更新核心WordPress

如果您的服务器使用的是PHP 7+,则此错误的最可能原因是您运行的是旧版本的WordPress。如果您使用WordPress 3.9或更低版本,则可能会触发此错误。

因此,修复方法是更新您的WordPress软件,该软件还将带来许多其他功能、安全性和性能改进。

要手动升级您的WordPress版本,首先,请确保您有网站的备份版本。然后,转到WordPress.org并下载最新的WordPress副本。

下载后,将zip文件解压缩到您的计算机。然后,打开包含所有WordPress文件的文件夹并删除以下项目:

  • wp-config-sample.php文件。
  • wp-config.php文件(您可能看不到这个文件-只需确保删除它,如果它的存在)。
  • wp-content的文件夹。

删除这些项目后,通过FTP将剩余的文件/文件夹上传到您的服务器。当您的FTP客户端提示重复文件时,告诉它覆盖所有文件:

通过覆盖现有文件重新安装WordPress

通过覆盖现有文件重新安装WordPress

文件上传完成后,您的WordPress站点应该运行最新版本,并且您的问题应该得到解决。

作为后续步骤,您还应该确保将所有插件和主题也更新到最新版本。

3.检查是否安装了MySQL扩展

如果您的服务器仍在使用PHP 5.6或更低版本,则您的服务器可能缺少WordPress所需的 MySQL 扩展。

要检查是否是这种情况,请返回您在步骤1中上传到服务器的phpinfo.php文件。

查找名为mysqlmysqli的部分。

如果安装了MySQL扩展,您应该会在Client API library version项旁边看到一个版本号:

如何查看是否安装了WordPress MySQL扩展

如何查看是否安装了WordPress MySQL扩展

如果找不到此信息,则表示未安装MySQL扩展。最好的解决方案通常是联系您的主机的支持人员并要求他们为您安装它。

注意– 我们再次强烈建议不要使用低于7.4的PHP版本,因为它们不再接收安全更新并且性能不如新版本。

除非您绝对必须继续使用PHP 5.6或更低版本,否则更好的解决方案是将您的服务器升级到PHP 7.4+,而不是花时间正确配置旧版本的PHP。

4. 确保PHP扩展配置正确

如果您使用的是 PHP 5.6 或更低版本并且安装了扩展,则问题可能是它没有正确配置。两个常见的问题是:

  • 在使用 Linux 服务器时上传用于 Windows 服务器的php.ini文件
  • 文件路径不正确。

您可以在之前创建的phpinfo.php文件中找到php.ini文件的位置:

如何找到WordPress php.ini文件路径

如何找到WordPress php.ini文件路径

首先,我们建议通过将现有文件下载到您的本地计算机来备份它。然后,尝试删除php.ini文件,看看是否能解决问题。

小结

“您的PHP安装似乎缺少WordPress所需的MySQL扩展”消息是一个令人沮丧的错误,因为它看起来非常技术性。

但是,通过本文中的步骤,您应该能够诊断并修复问题。

我们推荐的解决方案是确保您使用的是最新版本的PHP和WordPress。

如果您使用PHP 7.4+和WordPress 5.0+,您应该能够自动修复此错误并使您的站点重新运行,同时还可以从更新带来的所有其他性能、安全性和功能增强中受益。

香港110M(含10M CN2)大带宽独服限量促销,香港E3-8G-1T硬盘-3IP,月付仅799!
赞(0) 打赏
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权, 转载请注明出处。
文章名称:《修复“您的PHP安装似乎缺少WordPress所需的MySQL扩展”错误》
文章链接:https://cnidc.co/21870.html
【声明】:国外主机测评仅分享信息,不参与任何交易,也非中介,所有内容仅代表个人观点,均不作直接、间接、法定、约定的保证,读者购买风险自担。一旦您访问国外主机测评,即表示您已经知晓并接受了此声明通告。
【关于安全】:任何 IDC商家都有倒闭和跑路的可能,备份永远是最佳选择,服务器也是机器,不勤备份是对自己极不负责的表现,请保持良好的备份习惯。
标签:
广告位招租,欢迎骚扰
香港110M(含10M CN2)大带宽独服限量促销,香港E3-8G-1T硬盘-3IP,月付仅799!

觉得文章有用就打赏一下文章作者

非常感谢你的打赏,我们将继续给力更多优质内容,让我们一起创建更加美好的网络世界!

支付宝扫一扫打赏

微信扫一扫打赏